GSP Rocket Status - Rocket Problem – Incident details

All systems operational

Rocket Problem

Resolved
Partial outage
Started over 3 years agoLasted 6 minutes

Affected

Rocket Status

Partial outage from 1:44 PM to 1:50 PM

Updates
  • Resolved
    Resolved

    The issue has been fixed! The rocket has passed 2nd stage separation and is on it's way to space!

  • Monitoring
    Monitoring

    The rocket launched but there is an engine problem. We are quickly working to resolve this.